Mark@gement

un management humaniste tendu vers les clients

Rostand
Automate

L’automate est une illustration d’un comportement pratiquement imprévisible en avenir déterministe. Son principe est que chaque case d’une ligne d’un tableur (type Excel) prend la valeur 0 ou 1 en fonction du total des 3 cases qui la surmontent. Au bout de quelques dizaines de lignes, la modification de la valeur d’une case de la première ligne entraîne une telle cascade de modifications dans les lignes suivantes qu'il devient impossible de deviner (sans effectuer tous les calculs) la variation de valeur d’une case de la dernière ligne.

Un tel automate peut se télécharger ou se fabriquer comme suit sur un tableur :

•    Ecrivez sur la première ligne une centaine de 1 ou de 0 (ou case vide) dans les colonnes successives d’une feuille. Par exemple de la colonne A à la colonne CP.

•    Choisissez librement la valeur 0 ou 1 que prendra chaque case de la ligne suivante selon que la somme des 3 cases qui la surmonte est égale à 0, 1, 2 ou 3. Par exemple = 0 si la somme est inférieure à 3 et 1 si elle atteint cette valeur.

•    Dans l'hypothèse ci-dessus, programmez la case la plus à gauche (colonne A) de la ligne N°2 avec la formule suivante :

=SI(CP1+A1+B1=0;0;SI(CP1+A1+B1=1;1;SI(CP1+A1+B1=2;0;SI(CP1+A1+B1=3;0;1))))

•    Dans la colonne B de la même ligne 2 placer la formule :

=SI(A1+B1+C1=0;0;SI(A1+B1+C1 =1;1;SI(A1+B1+C1 =2;0;SI(A1+B1+C1 =3;0;1))))

•    Copier à droite cette formule jusqu’à la colonne CO incluse

•    Dans la case suivante (CP2), pour obtenir un automate circulaire, la formule est :

=SI(CO1+CP1+A1=0;0;SI(CO1+CP1+A1 =1;1;SI(CO1+CP1+A1 =2;0;SI(CO1+CP1+A1 =3;0;1))))

•    Copier la totalité de cette ligne 2 vers le bas jusque, par exemple, la ligne 100

•    Votre modèle est prêt : enregistrez le

Modifiez la valeur 1 ou 0 (“rien”) d’une des cases de la ligne 1 et observez ce qui se passe : une perturbation se propage vers le bas et progressivement en largeur. On obtient une nouvelle apparence pseudo régulière, mais il est pratiquement impossible de prévoir si la valeur d’une case donnée de la ligne 100 sera modifiée ou non.

On est en présence d'un résultat imprévisible intuitivement bien que déterministe : seul le calcul peut apporter la réponse ... même s'il est vrai que vous n'avez qu'une chance sur deux de vous tromper !

A noter que l’ensemble des lignes et colonnes qui ne présente pas un aspect anarchique, mais garde un aspect général ordonné pseudo régulier est typique d'une propriété que l'on constate souvent dans les systèmes complexes : ils ont tendance à s'auto-organiser.

Dans le management, on a souvent à prendre en compte de nombreux paramètres qui génèrent une imprévisibilité d'autant plus grande que, contrairement au cas de l'automate ci contre, on ne connaît pas les règles d'interaction entre les éléments. Il ne faut pas chercher à tout organiser dans tous les détails, mais faire confiance à une certaine aptitude de l'ensemble à trouver une solution inédite à un problème nouveau.

Pour s'amuser un peu : remplacez la première ligne de votre tableur par la séquence suivante :

1    1        1                1    1    1    1                1        1    1            1    1    1    1        1    1        1                1            1                1        1        1 1 1                    1    1                1            1                    1    1    1    1                    1    1    1            1    1        1    1    1        1        1    1        1    1        1

Changez le "1 orange" en "0". Vous avez l'impression que rien n'a changé ... vous avez raison : la modification d'un chiffre de la première rangée n'entraîne pas forcément un boulversement de l'ensemble.

Puisse cet exercice vous rendre plus attentif au comportement souvent imprévisible des systèmes complexes ...

Mkgt logo